Posts Tagged ‘udev’

Debian Unstable 2 Abril + KDE 4.6

abril 8, 2011

Actualizo a la vez el Debian Unstable de Diciembre 2010 a 2 Abril 2011 (Fechas aproximadas) y a la vez el KDE 4.6 gracias al repositorio: http://qt-kde.debian.net/

Para actualizar todo (en mi caso que ya tenía un kde 4.5.X no oficial):

apt-get -t experimental-snapshots dist-upgrade

Parece ser que udev tiene un problema:

cannot create /run/udev//root-link-rule

Para arreglarlo simplemente hay que hacer:

mv /run /run-borrado

Y esto hace que haya muchos modulos que no carguen correctamente como por ejemplo la red inalambrica, el touchpad y el sonido.

Cuando no sabía esto del udev intenté hacer funcionar alguna de estas cosas a mano. Lo dejo aqui apuntado por si hay algún usuario con el udev roto o algo así.

Para hacer funcionar inalambrico:

http://wiki.debian.org/wl#Squeeze

Editar /etc/modules :

* Comentar ndiswrapper

* Añadir: wl

Para hacer funcionar audio:

He hecho esto que creo que no me hubiera hecho falta:

apt-get install alsa-base
dpkg-reconfigure linux-sound-base

para seleccionar alsa.

Finalmente he añadido la linea:

snd_hda_intel

al fichero /etc/modules .

Problema initramfs-tools al actualizar a Ubuntu 9.04

mayo 7, 2009

Como ya  os contaba en el post de la clonación tenía problemas con paquetes no encontrados. Ahora ya tengo todos los paquetes puesto que volví a ejecutar apt-mirror como ya indiqué en el truco de apt-mirror.

Ahora he intentado hacer el apt-get dist-upgrade.

Se detiene en:

mkdir: no se puede crear el directorio «/tmp/mkinitramfs_hoESCF/etc/udev/rules.d»: El fichero ya existe
cpio: ./sbin/udevsettle: No se puede stat: No existe el fichero ó directorio
cpio: ./sbin/udevtrigger: No se puede stat: No existe el fichero ó directorio
cpio: ./bin/udevinfo: No se puede stat: No existe el fichero ó directorio
dpkg: el subproceso post-installation script devolvió el código de salida de error 1

Al principio creía que era por mis paquetes codip2p del proyecto desdeslin pero no era así porque tenía la versión del initramfs-tools era la de jaunty.

Al final lo que he hecho ha sido enlazar udevsettle y udevtrigger al binario true.

Con udevinfo no había manera así que he tenido que editar un fichero de configuración de initramfs-tools (Vaya ahora mismo no tengo la ruta) para que hiciera caso omiso del mismo. Para que no lo copiaran.

En Ubuntu (y no sé si en Debian) esos tres comandos se han substituido por uno nuevo que hace las veces de ellos.

Pero no sé por qué el initramfs-tools sigue haciendo referencia a ellos.

Todo esto lo he hecho offline y es posible que actualice este post con enlaces a gente que le ha haya pasado lo mismo y con su solución.