Archive for the ‘Uncategorized’ Category

Livebox Orange detrás de router neutro Mikrotik con VoIP funcionando

mayo 22, 2017

Livebox Orange detrás de router neutro Mikrotik con VoIP funcionando

Objetivos

  • Evitar los cortes a Internet que el router por defecto de Orange (Livebox) genera durante el día
  • Control más personalizado de la conexión a Internet
  • Seguir disfrutando de la VoIP ofrecida por Livebox Orange

Diferencias con otros howtos

  • Se securiza la interfaz pública del router Mikrotik. (En el resto de howtos no se cae en la cuenta de que se deja la interfaz pública abierta. Es decir, que si no cambiamos la contraseña nos pueden entrar por ssh al Mikrotik desde el exterior.)
  • Está en una sola página y no has de elegir en un foro cuál es el post correcto
  • Basada en red 192.168.1.1/24 (se conserva esta porque se heredó de una red de Teléfonica / Movistar ADSL)
  • QoS para VozIP (En realidad esto al final no se implementó pero lo suyo sería que un howto de estas características configurase el Mikrotik para que este tráfico tuviera tráfico sobre el resto.)
  • En la medida de lo posible se explican los diferentes pasos realizados y no es un simple “Copiar y pegar todos los comandos”
  • Se conecta al Microtik mediante ssh en lugar de con winbox o utilidades similares
  • No se sacaran passwords de SIP del Livebox para sustituir por un dispositivo VoIP

Arquitectura física antes de la mejora

  • LiveBox conectado mediante “clavija Fibra” a ONT (Terminal de fibra óptica). (El modelo de la ONT es ONT F601.)
  • PCs y clientes VoIP conectados a “clavija 1”, “clavija 2”, “clavija 3”, “clavija 4” y “clavija 5” de LiveBox

Arquitectura física después de la mejora

  • Mikrotik conectado mediante “puerto 2” a ONT
  • Livebox conectado mediante “clavija Fibra” a “puerto 24” de Mikrotik
  • Livebox conectado mediante “clavija 1” a “puerto 2” de Mikrotik
  • PCs y clientes VoIP conectados a “clavija 2, “clavija 3” y “clavija 4” de Mikrotik

Arquitectura lógica antes de la mejora

  • Todos los PCS y clientes VoIP tienen como puerta enlace: 192.168.1.1 que es la ip asignada al Livebox
  • Los clientes VoIP se conectan contra 192.168.1.1 (Livebox)
  • Microtik no existe en la red
  • Livebox tiene la ip 192.168.1.1 (configurada en sus bocas LAN)
  • Livebox tiene la ip pública (En su clavija Fibra)
  • Livebox ofrece DHCP a la red

Arquitectura lógica después de la mejora

  • Todos los PCS y clientes VoIP tienen como puerta enlace: 192.168.1.1 que es la ip asignada al Mikrotik
  • Los clientes VoIP se conectan contra 192.168.1.2 (Livebox)
  • Mikrotik tiene la ip 192.168.1.1 (En sus puertos 2,3 y 4)
  • Mikrotik tiene la ip pública (En su puerto 1)
  • Mikrotik tiene la ip 192.168.99.1 (En su puerto 5)
  • Livebox tiene la ip 192.168.1.2 (configurada en sus bocas LAN)
  • Livebox tiene la ip 192.168.99.2 (En su clavija Fibra)
  • Livebox NO ofrece DHCP a la red
  • Mikrotik ofrece DHCP a la red

Materiales

  • Livebox
  • Mikrotik CRS125-24G-1S-RM (También aplicable a Mikrotik 750 y otros modelos)
  • PC con tarjeta de red provista de clavija ethernet RJ-45
  • Dispositivo VoIP (Opcional si podemos usar el PC)
  • Cable de red ( 4 cables mínimos )

Cómo conectarse al Livebox

  • Podemos conectarnos por cable
  • Podemos conectarnos por wifi
  • El PC lo tendremos que configurar, para mayor comodidad, para trabajar con ip estática y en el mismo rango que el Livebox.
  • Abrimos un navegador web y lo apuntamos a la ip (que tenga en ese momento el Livebox) es decir, por ejemplo,: http://192.168.1.1/

Cómo conectarse al Microtik

  • Sólo podemos conectarnos por cable (este modelo no tiene Wifi). Aún así, aunque tuviera wifi lo recomendable es conectarse por cable.
  • El PC lo tendremos que configurar, para mayor comodidad, para trabajar con ip estática y en el mismo rango que el de Microtik.
  • Abrimos un cliente SSH (putty en Windows) y lo apuntamos a la ip (que tenga en ese momento el Microtik) con el usuario: admin . Por ejemplo:  admin@192.168.88.1 .
  • Nos conectamos al puerto 2

Describiremos cómo configuramos el Mikrotik.

Configuración de red del PC

Para conectarse al router tenemos que configurar la red de nuestro PC para interactuar con él. Recordemos que la ip por defecto de Mikrotik es: 192.168.88.1 .

IP: 192.168.88.10
Mascara de red: 255.255.255.0

service network-manager stop
ifconfig eth0 192.168.88.10 netmask 255.255.255.0

Conexión inicial a Mikrotik

Nos conectamos al router por ssh en el puerto 3.

ssh -p 22 admin@192.168.88.1

Aceptamos la key.

Nos aparece algo parecido a:

  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS X.YY.Z (c) 1999-2016       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level
The following default configuration has been installed on your router:
-------------------------------------------------------------------------------
Switch mode:
 * all interfaces switched;
 * IP address 192.168.88.1/24 is set on LAN port
LAN Configuration:
    switch group: ether1 (master), ether2, ether3, ether4,
 ether5, ether6, ether7, ether8, ether9, ether10, ether11,
 ether12, ether13, ether14, ether15, ether16, ether17,
 ether18, ether19, ether20, ether21, ether22, ether23,
 ether24, sfp1

-------------------------------------------------------------------------------
You can type "v" to see the exact commands that are used to add and remove
this default configuration, or you can view them later with
'/system default-configuration print' command.
To remove this default configuration type "r" or hit any other key to continue.
If you are connected using the above IP and you remove it, you will be disconnected.

Pulsamos cualquier tecla para continuar.

Ahora por comodidad vamos a hacer un dump de la configuración actual.

/export file=dump_inicial_20170522

Con scp (desde el PC) podemos obtener este dump.

scp -P 22 admin@192.168.88.1:dump_inicial_20170522.rsc .

Configuración vlan 832 ONT

Ya que todos los puertos hacen bridge por defecto con ether1-master haremos que el puerto 2 tenga configurada la vlan 832. Esto nos permitirá interactuar con la ONT de Orange.
Así mismo esto nos facilitará configurar el router de forma más sencilla más adelante para que tenga la configuración de red 192.168.1.X .

Para que Mikrotik interactue con Orange no sólo ha de configurarse la vlan 832 si no que también se ha de configurar como un cliente dhcp de la misma.

Primero separaremos el puerto 2.

/interface ethernet
set [ find default-name=ether2 ] master-port=none

Lo definimos como vlan.

/interface vlan
add interface=ether2 name=ether2-vlan832 vlan-id=832

Y configuramos el cliente de dhcp.

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether2-vlan832

Nueva red 192.168.1.X

Primero añadiremos una red extra a Mikrotik

/ip address
add address=192.168.1.1/24 interface=ether1-master network=192.168.1.0

Ahora nos desconectamos de nuestro router Mikrotik.

/quit

Configuramos nuestro PC para trabajar con:

IP: 192.168.1.10
Mascara de red: 255.255.255.0

ifconfig eth0 192.168.1.10 netmask 255.255.255.0

y nos conectamos ahora con:

ssh -p 22 admin@192.168.1.1

(En este punto aceptamos la key ssh).

Ahora ya podemos quitar la red por defecto.

/ip address print

nos muestra:

 #   ADDRESS            NETWORK         INTERFACE                                                                                                                                          
 0   ;;; defconf
     192.168.88.1/24    192.168.88.0    ether1-master                                                                                                                                      
 1   192.168.1.1/24     192.168.1.0     ether1-master

Ahí vemos como la red por defecto es 0. La quitaremos.

/ip address remove 0

con lo que nos quedará:

/ip address print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                                                                                                                                          
 0   192.168.1.1/24     192.168.1.0     ether1-master

Así mismo configuaremos dhcp en esta red porque usaremos el propio Mikrotik como servidor dhcp.

/ip pool
add name=dhcp_pool1 ranges=192.168.1.30-192.168.1.250
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether1-master lease-time=3d
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=62.36.225.150,62.37.228.20 gateway=\
    192.168.1.1

Puerto 24 (puerto 5 en routers más pequeños) para Livebox

Este tiene que tener la vlan 832 así así como ofrecer un servidor dhcp al Livebox.

# Separamos
/interface ethernet
set [ find default-name=ether24 ] master-port=none
# Vlan
/interface vlan
add interface=ether24 name=ether24-vlan832 vlan-id=832
# Servidor DHCP
/ip pool
add name=dhcp_pool2 ranges=192.168.99.2
/ip dhcp-server
add address-pool=dhcp_pool2 disabled=no interface=ether24-vlan832 lease-time=3d
/ip dhcp-server network
add address=192.168.99.0/24 gateway=192.168.99.1

Salir a Internet por la ONT

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether2-vlan832

Firewall para Internet

/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=input comment=\
    "Drop de todo lo que viene desde nuestra WAN" in-interface=ether2-vlan832
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "Drop de todo lo que viene de la WAN que no esta DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface=\
    ether2-vlan832

Recuperar red en PC de configuración

Opcionalmente podemos hacer:

service network-manager start

 

 

 

Cambiar contraseña

/user set 0 password="MuYSecr3to"

Desactivar accesos alternativos a ssh (opcional)

/ip service
set telnet disabled=yes
set www disabled=yes
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes

Desconectar y conectar todo de nuevo

Apagamos con:

/system shutdown

y pulsamos y para confirmar.

Ahora ya podemos poner el router en su localización final.

  • El PC de prueba (que esta vez deberá configurarse como un cliente dhcp normal) se conecta al puerto 3 del Mikrotik.
  • La ONT se conecta al puerto 2 del Mikrotik.
  • Livebox conectado mediante “clavija Fibra” a “puerto 24” de Mikrotik.

Mejoras posibles

  • Tráfico VoIP priorizado
  • Actualización del firmware del router

Referencia – Configuración Mikrotik – Dump inicial

# jan/02/1970 00:46:30 by RouterOS X.YY.Z
# software id = LLYC-IDAG
#
/interface ethernet
set [ find default-name=ether1 ] name=ether1-master
set [ find default-name=ether2 ] master-port=ether1-master
set [ find default-name=ether3 ] master-port=ether1-master
set [ find default-name=ether4 ] master-port=ether1-master
set [ find default-name=ether5 ] master-port=ether1-master
set [ find default-name=ether6 ] master-port=ether1-master
set [ find default-name=ether7 ] master-port=ether1-master
set [ find default-name=ether8 ] master-port=ether1-master
set [ find default-name=ether9 ] master-port=ether1-master
set [ find default-name=ether10 ] master-port=ether1-master
set [ find default-name=ether11 ] master-port=ether1-master
set [ find default-name=ether12 ] master-port=ether1-master
set [ find default-name=ether13 ] master-port=ether1-master
set [ find default-name=ether14 ] master-port=ether1-master
set [ find default-name=ether15 ] master-port=ether1-master
set [ find default-name=ether16 ] master-port=ether1-master
set [ find default-name=ether17 ] master-port=ether1-master
set [ find default-name=ether18 ] master-port=ether1-master
set [ find default-name=ether19 ] master-port=ether1-master
set [ find default-name=ether20 ] master-port=ether1-master
set [ find default-name=ether21 ] master-port=ether1-master
set [ find default-name=ether22 ] master-port=ether1-master
set [ find default-name=ether23 ] master-port=ether1-master
set [ find default-name=ether24 ] master-port=ether1-master
set [ find default-name=sfp1 ] master-port=ether1-master
/interface ethernet switch port
set 0 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 1 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 2 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 3 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 4 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 5 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 6 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 7 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 8 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 9 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 10 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 11 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 12 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 13 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 14 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 15 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 16 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 17 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 18 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 19 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 20 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 21 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 22 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 23 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 24 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 25 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether1-master network=\
    192.168.88.0
/system routerboard settings
set boot-device=flash-boot protected-routerboot=disabled

Referencia – Configuración Mikrotik final

# jan/02/1970 03:12:33 by RouterOS X.YY.Z
# software id = LLYC-IDAG
#
/interface ethernet
set [ find default-name=ether1 ] name=ether1-master
set [ find default-name=ether3 ] master-port=ether1-master
set [ find default-name=ether4 ] master-port=ether1-master
set [ find default-name=ether5 ] master-port=ether1-master
set [ find default-name=ether6 ] master-port=ether1-master
set [ find default-name=ether7 ] master-port=ether1-master
set [ find default-name=ether8 ] master-port=ether1-master
set [ find default-name=ether9 ] master-port=ether1-master
set [ find default-name=ether10 ] master-port=ether1-master
set [ find default-name=ether11 ] master-port=ether1-master
set [ find default-name=ether12 ] master-port=ether1-master
set [ find default-name=ether13 ] master-port=ether1-master
set [ find default-name=ether14 ] master-port=ether1-master
set [ find default-name=ether15 ] master-port=ether1-master
set [ find default-name=ether16 ] master-port=ether1-master
set [ find default-name=ether17 ] master-port=ether1-master
set [ find default-name=ether18 ] master-port=ether1-master
set [ find default-name=ether19 ] master-port=ether1-master
set [ find default-name=ether20 ] master-port=ether1-master
set [ find default-name=ether21 ] master-port=ether1-master
set [ find default-name=ether22 ] master-port=ether1-master
set [ find default-name=ether23 ] master-port=ether1-master
set [ find default-name=sfp1 ] master-port=ether1-master
/interface vlan
add interface=ether2 name=ether2-vlan832 vlan-id=832
add interface=ether24 name=ether24-vlan832 vlan-id=832
/ip pool
add name=dhcp_pool1 ranges=192.168.1.30-192.168.1.250
add name=dhcp_pool2 ranges=192.168.99.2
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether1-master lease-time=3d \
    name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=ether24-vlan832 lease-time=\
    3d name=dhcp2
/interface ethernet switch port
set 0 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 1 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 2 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 3 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 4 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 5 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 6 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 7 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 8 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 9 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0:\
    8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 10 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 11 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 12 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 13 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 14 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 15 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 16 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 17 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 18 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 19 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 20 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 21 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 22 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 23 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 24 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
set 25 per-queue-scheduling="wrr-group0:1,wrr-group0:2,wrr-group0:4,wrr-group0\
    :8,wrr-group0:16,wrr-group0:32,wrr-group0:64,wrr-group0:128"
/ip address
add address=192.168.1.1/24 interface=ether1-master network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether2-vlan832
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=62.36.225.150,62.37.228.20 gateway=\
    192.168.1.1
add address=192.168.99.0/24 gateway=192.168.99.1
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=input comment=\
    "Drop de todo lo que viene desde nuestra WAN" in-interface=ether2-vlan832
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "Drop de todo lo que viene de la WAN que no esta DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface=\
    ether2-vlan832
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether2-vlan832
/system routerboard settings
set boot-device=flash-boot protected-routerboot=disabled

Referencia – Configuración Mikrotik final (Sistema alternativo 750)

# En este sistema antiguo los puertos tenían bridge
# por defecto con ether2-master y no con ether1-master
# se decidió pues usar el puerto 1 para conectar con la ONT.


# mar/31/2017 09:01:00 by RouterOS X.YY.Z
# software id = NQ5I-YFZV
#
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
/ip neighbor discovery
set ether1 discover=no
/interface vlan
add interface=ether1 name=eth1-vlan832 vlan-id=832
add interface=ether5 name=eth5-vlan832 vlan-id=832
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_pool1 ranges=192.168.1.30-192.168.1.250
add name=dhcp_pool2 ranges=192.168.99.2
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether2-master lease-time=3d \
    name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=eth5-vlan832 lease-time=3d \
    name=dhcp2
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/ip address
add address=192.168.1.1/24 interface=ether2-master network=192.168.1.0
add address=192.168.99.1/24 interface=eth5-vlan832 network=192.168.99.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=eth1-vlan832
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=62.36.225.150,62.37.228.20 gateway=\
    192.168.1.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
add address=192.168.99.0/24 gateway=192.168.99.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=input comment=\
    "Drop de todo lo que viene desde nuestra WAN" in-interface=eth1-vlan832
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "Drop de todo lo que viene de la WAN que no esta DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface=\
    eth1-vlan832
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    out-interface=ether1
add action=masquerade chain=srcnat out-interface=eth1-vlan832
/ip service
set telnet disabled=yes
set www disabled=yes
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Madrid
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master
/tool user-manager database
set db-path=user-manager
Anuncios

A la sonrisa rusa

marzo 13, 2017

Se habla de un caminante perdido,
transitaba por la fría tundra.

La suerte dio con él,
floreció una rosa naranja,
en el paisaje blanco,
pudo él admirarla.

La leyenda cuenta,
es la flor escueta,
pues un sólo día,
en todo el invierno,
ella florece.

Aquél que la encontrase,
no olvidaría el recuerdo,
de su singular imagen,
ningún día de su vida.

Al salir del ascensor,
con tus labios carmesí,
de frente me encontré,
fue entonces cuando supe,
que tú en efecto eras,
mi rosa rusa anaranjada.

La entrega

febrero 12, 2017

Salvo menores,
todo analizado,
aquí se ha acabado,
brota nueva vida,
que ha empezado.

Dos vinilos,
uno resultante,
del otro fuente.

Resarcir la afrenta,
objetivo inalcanzable,
mas suavizar la misma,
mi objetivo loable.

Mi olvido reafirmo,
sepa vuestra merced,
tercero desde aulos,
resalto buscado.

El segundo figurante,
por fin coronado,
mas aquí sólo honrado
y bien acompañado.

De la música disfrute,
de lo que no llegó,
para siempre: ¡Descarte!

Show kde activity name plasmoid

febrero 10, 2017

Introduction

I use Kde activities a lot and I want a simple plasmoid which shows the current activity I’m in. I have so many activities that the activity switcher (not sure of the correct name) would be too big for me to be usable.

 

There’s a plasmoid which it’s aimed originally aimed at showin current application name which we can install and setup so that it shows current activity.

 

application-name plasmoid showing an activity name in a panel

application-name plasmoid showing an activity name in a panel

Its name it’s applicationname-plasmoid .

Fetch and Installation

This installation it’s aimed to your current user. It won’t make the plasmoid available for the rest of the users of your machine.

git clone https://github.com/ilpianista/applicationname-plasmoid
cd applicationname-plasmoid/
zip applicationname.zip package -r
plasmapkg -i applicationname.zip
kbuildsycoca4

Setup

From a panel. Add graphical items. Filter by ‘name’ or search for ‘Application Name’. Double click on it for adding it to the panel.

Then right-click on it. Settings. Select “Always (never display app title)” at the “Show activity name” dropdown. You can optionally set a fixed width too. Finally you just need to click on OK to save the new settings.

 

 

application-name plasmoid Settings window

application-name plasmoid Settings window

KDE Activities Support for Firefox (Part 1 of 4)

febrero 9, 2017

KDE Activities Support for Firefox (Part 1 of 4)

Part 1: Firefox Accounts local server

Part 2: Firefox Sync-1.5 Server

Part 3: firefoxkde script setup

Part 4: Sync of bookmarks on different profiles

Firefox Accounts local server

Requisites

Nodejs > 4.5.0 (As per Fxa Auth Server requisites)

Nodejs from Jessie is 0.10.29. We need to install it from source. However we will use an special deb repository for that

curl -sL https://deb.nodesource.com/setup_7.x |\
 sudo -E bash -
sudo apt-get install nodejs

Git

sudo apt-get update
sudo apt-get install git

Fxa Auth Server

Fetching Fxa Auth Server

This is one of the two components needed. It’s an auth server.

mkdir fxa-auth-server
cd fxa-auth-server
git clone https://github.com/mozilla/fxa-auth-server/

Fxa Auth Server Requisites

Node >= 4.5.0

We already have it.

Npm

Nodejs 7.x already provides it.

Grunt

# As a new fxaauth user
npm install grunt

Fxa Auth Server Installation

# As the new fxaauth user
cd fxa-auth-server
npm install

Testing Fxa Auth Server

# As the new fxaauth user
cd fxa-auth-server
npm start

Example of server starting ok:

fxa-auth-server.INFO: server.start.1 {"op":"server.start.1","msg":"running on http://127.0.0.1:9000"}

Additional Links

 

El cuento de la quesera

enero 11, 2017

La primera fuiste
te odiara pedirme.

Rechazo obvio,
lo eras todo,
¿Cómo no amarte?

En contadas ocasiones,
hacía ti proyecto,
el enfado infantil,
pues todo lo tenía,
mas pobre de mi,
después desvanecía.

Mas sé que yerro,
puesto tu cuento,
el de la quesera,
lo di por sentado.

Frecuencia asegurada,
terna condicionada,
apetito desbocado,
todo era tan alocado.

Dos décadas pasando,
viviendo en lo virtual,
estando pero no siendo,
tenía que ser ese final.

No lo necesitaba.

En verdad siento,
mas si mi retiro,
tan, oh, literal,
no hubiese sido,
de los dos pares,
miel degustare.

Parsimonía

diciembre 10, 2016

Segunda unidad mediaba,
después del Sol altivo,
silueta borrosa cruzaba.

La vista dirijo,
blanco encuadrado,
sólo diviso,
azul encuadrado,
sólo atisbo.

No está claro,
pero, oh, sí,
es el estampado.

La silueta se aleja,
paso tras paso,
parsimonía se refleja.

Ya no la siento,
Penélope no existe,
grato alivio,
pero vacío me siento.

La vida ha superado,
su andar trasciende,
como diente de león,
discreto y liviano.

Pesares no tiene,
feliz es bien ella,
pues son sus reglas,
a las que se atiene.

Ironía me persigue,
pues alma desaparece,
mas cuerpo resplandece,
aquel que escondías,
su potencial amagabas,
y yo lo ignoraba,
en sueños hoy tiene,
el lugar que se merece.

Epifanía de la luz

noviembre 9, 2016

A mis ojos miraste,
¡Me gustas! dijiste.
Nada entiendo repliqué,
¡Mujeres! replicaste.

La almohada consultaste,
lo que en mi buscabas,
del todo no hallabas.

Tu imagen de mi ser,
súbita se desvanecía,
cual rocío al mediodía.

Gran oportunidad asomaba,
después de un día postrado,
pros y contras evaluados,
por ti del todo apostaba.

La imagen de tu ser,
a los tres días,
de mi se apoderaba.

Como un globo infinito,
día tras día,
bondad le insuflaba,
día tras día,
sabiduría le insuflaba,
día tras día,
alegría le insuflaba.

Cuatro lunas pasaron,
la realidad a un lado,
mi realidad al otro.

Con mi silencio yerro,
pupila del todo ensangrentada,
no sólo te la muestro,
mas callo mi música peleada.

En el segundo acto,
requieres mi amnesía,
temes represalía,
nada más errada,
en esa noche estelada,
del todo estuviste.

Aunque lo aceptaba,
no lo comprendía,
basten estas líneas,
por fin, epifanía.

Después de juzgarte,
resulté botarate,
pues cuatro lunas,
contra una sola noche,
sólo soy un fantoche.

Si yo amase a Mamobau

noviembre 3, 2016

Abrumadoramente confiada,
teoría abajo, teoría arriba,
la chica se identifica,
con la serie más fantasía.

Guardo tu imagen pulcra,
como un tesoro,
vayas de uniforme,
o con el pelo escarlata.

A lo vintage o esquemática,
rubia quebradiza o de violeta,
la mujer de las miles facetas.

A Wally no lo encontré,
sonrisa ochentera mediante,
a ella sí la hallé.

De nuevo el corazón me palpita,
al verte tan diáfana.

Me destroza esa sonrisa,
que no dice nada
pero lo dice todo
de una bocanada.

Nunca desentonas,
siempre conjunto perfecto,
tú te lo enfundas.

Y al final,
me enamoran,
esas pecas,
que tu cuello adornan.

¡¿Quién? al Ministerio,
acceso tuviera!
Para coger la puerta,
que al principio,
junto a ti me dejara.

El segundo

octubre 8, 2016

Sobre mi abalanzaste,
aliento me robaste.

Bocados mediante,
mi mano guiaste.

Abracé la ternura,
efímero el instante,
mas el tacto perdura.

Sólo fue el segundo,
que cambió mi mundo.