Cpu de Xorg al 100% bien solucionado

Os comenté hace un tiempo que había solucionado el problema de Cpu de Xorg al 100%. Pues no era del todo cierto. Al cabo de unos días noté que el sistema iba lento. Es más seguía teniendo el mismo problema pero repartido de diferente manera.

Me explico. Podía más o menos usar el ordenador fluidamente porque la cpu estaba bastante libre pero esto era a costa de gastar gpu (y eso lo notaba por el ventilador del portátil que se ponía al 100%).

Ahora, no sé si habré solucionado que la CPU esté al 100% o no pero el KDE, más concretamente Kwin me va muy bien. He de decir que he mantenido el uso de efectos de escritorio (sin ninguno activado) para que la GPU siga interveniendo algo en la gestión de ventanas pero creo que desactivandolo igual ganaría algo de autonomía. Habría que experimentar con ello.

 

¿Como lo he hecho? Siguiendo unos pasos de: Fedorigen – Acelerar rendimiento de KDE. Concretamente el primer metodo.

Resumiendo. Editar:

/usr/share/autostart/plasma-desktop.desktop

para poder leer:

Exec=plasma-desktop -graphicssystem raster

Y editar:

/usr/bin/startkde

para poder leer:

kwrapper4 ksmserver $KDEWM -graphicssystem raster

.

 

Cerrar sesión y volver a entrar.

Funciona en mi KDE 4.6.2 del repositorio no oficial de Debian qt.

 

Anuncios

Etiquetas: , , , , ,

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s


A %d blogueros les gusta esto: